What’s Vulnerable › Vulnerabilities
CVE-2018-14058
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 28.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-08-17 · updated 2026-06-17
- Weakness: CWE-89
Description
Pimcore before 5.3.0 allows SQL Injection via the REST web service API.
Affected products
- pimcore/pimcore: before 5.3.0 — fixed in 5.3.0
How to fix
Upgrade to a fixed version: pimcore/pimcore 5.3.0. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/148954/Pimcore-5.2.3-CSRF-Cross-Site-Scripting-SQL-Injection.html
- http://seclists.org/fulldisclosure/2018/Aug/13
- https://www.exploit-db.com/exploits/45208/
- https://www.sec-consult.com/en/blog/advisories/sql-injection-xss-csrf-vulnerabilities-in-pimcore-software/
- http://packetstormsecurity.com/files/148954/Pimcore-5.2.3-CSRF-Cross-Site-Scripting-SQL-Injection.html
- http://seclists.org/fulldisclosure/2018/Aug/13
- https://www.exploit-db.com/exploits/45208/
- https://www.sec-consult.com/en/blog/advisories/sql-injection-xss-csrf-vulnerabilities-in-pimcore-software/
Get alerted when CVE-2018-14058 or the next vulnerability affects your stack