What’s Vulnerable › Vulnerabilities
CVE-2018-14346
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-07-17 · updated 2026-06-17
- Weakness: CWE-787
Description
GNU Libextractor before 1.7 has a stack-based buffer overflow in ec_read_file_func (unzip.c).
Affected products
- Debian Linux: 8.0, 9.0
- GNU libextractor: before 1.7 — fixed in 1.7
How to fix
Upgrade to a fixed version: GNU libextractor 1.7. Check the vendor advisory for mitigations.
References
- http://lists.gnu.org/archive/html/bug-libextractor/2018-07/msg00001.html
- https://gnunet.org/git/libextractor.git/commit/?id=ad19e7fe0adc99d5710eff1ed48d91a7b75a950e
- https://lists.debian.org/debian-lts-announce/2018/08/msg00025.html
- https://www.debian.org/security/2018/dsa-4290
- http://lists.gnu.org/archive/html/bug-libextractor/2018-07/msg00001.html
- https://gnunet.org/git/libextractor.git/commit/?id=ad19e7fe0adc99d5710eff1ed48d91a7b75a950e
- https://lists.debian.org/debian-lts-announce/2018/08/msg00025.html
- https://www.debian.org/security/2018/dsa-4290
Get alerted when CVE-2018-14346 or the next vulnerability affects your stack