What’s Vulnerable › Vulnerabilities
CVE-2018-14347
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-07-17 · updated 2026-06-17
- Weakness: CWE-835
Description
GNU Libextractor before 1.7 contains an infinite loop vulnerability in EXTRACTOR_mpeg_extract_method (mpeg_extractor.c).
Affected products
- Debian Linux: 8.0, 9.0
- GNU libextractor: before 1.7 — fixed in 1.7
How to fix
Upgrade to a fixed version: GNU libextractor 1.7. Check the vendor advisory for mitigations.
References
- http://lists.gnu.org/archive/html/bug-libextractor/2018-07/msg00000.html
- https://gnunet.org/bugs/view.php?id=5399
- https://gnunet.org/git/libextractor.git/commit/?id=f033468cd36e2b8bf92d747fbd683b2ace8da394
- https://lists.debian.org/debian-lts-announce/2018/08/msg00025.html
- https://www.debian.org/security/2018/dsa-4290
- http://lists.gnu.org/archive/html/bug-libextractor/2018-07/msg00000.html
- https://gnunet.org/bugs/view.php?id=5399
- https://gnunet.org/git/libextractor.git/commit/?id=f033468cd36e2b8bf92d747fbd683b2ace8da394
- https://lists.debian.org/debian-lts-announce/2018/08/msg00025.html
- https://www.debian.org/security/2018/dsa-4290
Get alerted when CVE-2018-14347 or the next vulnerability affects your stack