What’s Vulnerable › Vulnerabilities
CVE-2018-14357
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-17 · updated 2026-06-17
- Weakness: CWE-78
Description
An issue was discovered in Mutt before 1.10.1 and NeoMutt before 2018-07-16. They allow remote IMAP servers to execute arbitrary commands via backquote characters, related to the mailboxes command associated with an automatic subscription.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04
- Debian Linux: 8.0, 9.0
- mutt: before 1.10.1 — fixed in 1.10.1
- Neomutt: before 20180716 — fixed in 20180716
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Server Aus: 7.6, 7.7
- RedHat Enterprise Linux Server Eus: 7.5, 7.6, 7.7
- RedHat Enterprise Linux Server Tus: 7.6, 7.7
- RedHat Enterprise Linux Workstation: 6.0, 7.0
How to fix
Upgrade to a fixed version: mutt 1.10.1; Neomutt 20180716. Check the vendor advisory for mitigations.
References
- http://www.mutt.org/news.html
- https://access.redhat.com/errata/RHSA-2018:2526
- https://github.com/neomutt/neomutt/commit/e52393740334443ae0206cab2d7caef381646725
- https://gitlab.com/muttmua/mutt/commit/185152818541f5cdc059cbff3f3e8b654fc27c1d
- https://lists.debian.org/debian-lts-announce/2018/08/msg00001.html
- https://neomutt.org/2018/07/16/release
- https://security.gentoo.org/glsa/201810-07
- https://usn.ubuntu.com/3719-1/
- https://usn.ubuntu.com/3719-3/
- https://www.debian.org/security/2018/dsa-4277
- http://www.mutt.org/news.html
- https://access.redhat.com/errata/RHSA-2018:2526
Get alerted when CVE-2018-14357 or the next vulnerability affects your stack