What’s Vulnerable › Vulnerabilities
CVE-2018-14359
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-17 · updated 2026-06-17
- Weakness: CWE-120
Description
An issue was discovered in Mutt before 1.10.1 and NeoMutt before 2018-07-16. They have a buffer overflow via base64 data.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 18.04
- Debian Linux: 8.0, 9.0
- mutt: before 1.10.1 — fixed in 1.10.1
- Neomutt: before 20180716 — fixed in 20180716
How to fix
Upgrade to a fixed version: mutt 1.10.1; Neomutt 20180716. Check the vendor advisory for mitigations.
References
- http://www.mutt.org/news.html
- https://github.com/neomutt/neomutt/commit/6f163e07ae68654d7ac5268cbb7565f6df79ad85
- https://gitlab.com/muttmua/mutt/commit/3d9028fec8f4d08db2251096307c0bbbebce669a
- https://lists.debian.org/debian-lts-announce/2018/08/msg00001.html
- https://neomutt.org/2018/07/16/release
- https://security.gentoo.org/glsa/201810-07
- https://usn.ubuntu.com/3719-1/
- https://usn.ubuntu.com/3719-2/
- https://usn.ubuntu.com/3719-3/
- https://www.debian.org/security/2018/dsa-4277
- http://www.mutt.org/news.html
- https://github.com/neomutt/neomutt/commit/6f163e07ae68654d7ac5268cbb7565f6df79ad85
Get alerted when CVE-2018-14359 or the next vulnerability affects your stack