What’s Vulnerable › Vulnerabilities
CVE-2018-14380
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-18 · updated 2026-06-17
- Weakness: CWE-79
Description
In Graylog before 2.4.6, XSS was possible in typeahead components, related to components/common/TypeAheadInput.jsx and components/search/QueryInput.ts.
Affected products
- graylog2-server: before 2.4.6 — fixed in 2.4.6
How to fix
Upgrade to a fixed version: graylog2-server 2.4.6. Check the vendor advisory for mitigations.
References
- https://github.com/Graylog2/graylog2-server/pull/4904
- https://www.graylog.org/post/announcing-the-release-of-graylog-2-4-6
- https://github.com/Graylog2/graylog2-server/pull/4904
- https://www.graylog.org/post/announcing-the-release-of-graylog-2-4-6
Get alerted when CVE-2018-14380 or the next vulnerability affects your stack