What’s Vulnerable › Vulnerabilities
CVE-2018-14417
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 89.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-08-04 · updated 2026-06-17
- Weakness: CWE-78
Description
A command injection vulnerability was found in the web administration console in SoftNAS Cloud before 4.0.3. In particular, the snserv script did not sanitize the 'recentVersion' parameter from the snserv endpoint, allowing an unauthenticated attacker to execute arbitrary commands with root permissions.
Affected products
- Softnas Cloud: before 4.0.3 — fixed in 4.0.3
How to fix
Upgrade to a fixed version: Softnas Cloud 4.0.3. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2018/Jul/85
- http://www.securityfocus.com/bid/104914
- https://docs.softnas.com/display/SD/Release+Notes
- https://www.coresecurity.com/advisories/softnas-cloud-os-command-injection
- https://www.exploit-db.com/exploits/45097/
- http://seclists.org/fulldisclosure/2018/Jul/85
- http://www.securityfocus.com/bid/104914
- https://docs.softnas.com/display/SD/Release+Notes
- https://www.coresecurity.com/advisories/softnas-cloud-os-command-injection
- https://www.exploit-db.com/exploits/45097/
Get alerted when CVE-2018-14417 or the next vulnerability affects your stack