What’s Vulnerable › Vulnerabilities
CVE-2018-14618
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 11.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-09-05 · updated 2026-06-17
- Weakness: CWE-122
Description
curl before version 7.61.1 is vulnerable to a buffer overrun in the NTLM authentication code. The internal function Curl_ntlm_core_mk_nt_hash multiplies the length of the password by two (SUM) to figure out how large temporary storage area to allocate from the heap. The length value is then subsequently used to iterate over the password and generate output into the allocated storage buffer. On systems with a 32 bit size_t, the math to calculate SUM triggers an integer overflow when the password length exceeds 2GB (2^31 bytes). This integer overflow usually causes a very small buffer to actually get allocated instead of the intended very huge one, making the use of that buffer end up in a heap buffer overflow. (This bug is almost identical to CVE-2017-8816.)
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 18.04
- Debian Linux: 9.0
- curl: before 7.61.1 — fixed in 7.61.1
- Red Hat Enterprise Linux: 6.0, 7.0, 7.4, 7.5, 7.6
How to fix
Upgrade to a fixed version: curl 7.61.1. Check the vendor advisory for mitigations.
References
- http://www.securitytracker.com/id/1041605
- https://access.redhat.com/errata/RHSA-2018:3558
- https://access.redhat.com/errata/RHSA-2019:1880
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-14618
- https://cert-portal.siemens.com/productcert/pdf/ssa-436177.pdf
- https://curl.haxx.se/docs/CVE-2018-14618.html
- https://psirt.global.sonicwall.com/vuln-detail/SNWLID-2018-0014
- https://security.gentoo.org/glsa/201903-03
- https://usn.ubuntu.com/3765-1/
- https://usn.ubuntu.com/3765-2/
- https://www.debian.org/security/2018/dsa-4286
- http://www.securitytracker.com/id/1041605
Get alerted when CVE-2018-14618 or the next vulnerability affects your stack