What’s Vulnerable › Vulnerabilities
CVE-2018-14627
- Severity: medium (CVSS 5.9 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-09-04 · updated 2026-06-17
- Weakness: CWE-319
Description
The IIOP OpenJDK Subsystem in WildFly before version 14.0.0 does not honour configuration when SSL transport is required. Servers before this version that are configured with the following setting allow clients to create plaintext connections: <transport-config confidentiality="required" trust-in-target="supported"/>
Affected products
- Wildfly: before 14.0.0 — fixed in 14.0.0
How to fix
Upgrade to a fixed version: Wildfly 14.0.0. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2018:3527
- https://access.redhat.com/errata/RHSA-2018:3528
- https://access.redhat.com/errata/RHSA-2018:3529
- https://access.redhat.com/errata/RHSA-2018:3595
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-14627
- https://issues.jboss.org/browse/WFLY-9107
- https://security.netapp.com/advisory/ntap-20181221-0002/
- https://access.redhat.com/errata/RHSA-2018:3527
- https://access.redhat.com/errata/RHSA-2018:3528
- https://access.redhat.com/errata/RHSA-2018:3529
- https://access.redhat.com/errata/RHSA-2018:3595
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-14627
Get alerted when CVE-2018-14627 or the next vulnerability affects your stack