What’s Vulnerable › Vulnerabilities
CVE-2018-14629
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-11-28 · updated 2026-06-17
- Weakness: CWE-400
Description
A denial of service vulnerability was discovered in Samba's LDAP server before versions 4.7.12, 4.8.7, and 4.9.3. A CNAME loop could lead to infinite recursion in the server. An unprivileged local attacker could create such an entry, leading to denial of service.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 18.04, 18.10
- Debian Linux: 8.0, 9.0
- Samba: from 4.0.0 before 4.7.12; from 4.8.0 before 4.8.7; from 4.8.8 before 4.9.3 — fixed in 4.7.12, 4.8.7, 4.9.3
How to fix
Upgrade to a fixed version: Samba 4.7.12, 4.8.7, 4.9.3. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/106022
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-14629
- https://lists.debian.org/debian-lts-announce/2018/12/msg00005.html
- https://security.gentoo.org/glsa/202003-52
- https://security.netapp.com/advisory/ntap-20181127-0001/
- https://usn.ubuntu.com/3827-1/
- https://usn.ubuntu.com/3827-2/
- https://www.debian.org/security/2018/dsa-4345
- https://www.samba.org/samba/security/CVE-2018-14629.html
- http://www.securityfocus.com/bid/106022
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-14629
- https://lists.debian.org/debian-lts-announce/2018/12/msg00005.html
Get alerted when CVE-2018-14629 or the next vulnerability affects your stack