What’s Vulnerable › Vulnerabilities

CVE-2018-14630

Description

moodle before versions 3.5.2, 3.4.5, 3.3.8, 3.1.14 is vulnerable to an XML import of ddwtos could lead to intentional remote code execution. When importing legacy 'drag and drop into text' (ddwtos) type quiz questions, it was possible to inject and execute PHP code from within the imported questions, either intentionally or by importing questions from an untrusted source.

Affected products

How to fix

Upgrade to a fixed version: Moodle 3.1.14, 3.3.8, 3.4.5, 3.5.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2018-14630 or the next vulnerability affects your stack