What’s Vulnerable › Vulnerabilities

CVE-2018-14631

Description

moodle before versions 3.5.2, 3.4.5, 3.3.8 is vulnerable to a boost theme - blog search GET parameter insufficiently filtered. The breadcrumb navigation provided by Boost theme when displaying search results of a blog were insufficiently filtered, which could result in reflected XSS if a user followed a malicious link containing JavaScript in the search parameter.

Affected products

How to fix

Upgrade to a fixed version: Moodle 3.3.8, 3.4.5, 3.5.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2018-14631 or the next vulnerability affects your stack