What’s Vulnerable › Vulnerabilities
CVE-2018-14633
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-09-25 · updated 2026-06-17
- Weakness: CWE-121
Description
A security flaw was found in the chap_server_compute_md5() function in the ISCSI target code in the Linux kernel in a way an authentication request from an ISCSI initiator is processed. An unauthenticated remote attacker can cause a stack buffer overflow and smash up to 17 bytes of the stack. The attack requires the iSCSI target to be enabled on the victim host. Depending on how the target's code was built (i.e. depending on a compiler, compile flags and hardware architecture) an attack may lead to a system crash and thus to a denial-of-service or possibly to a non-authorized access to data exported by an iSCSI target. Due to the nature of the flaw, privilege escalation cannot be fully ruled out, although we believe it is highly unlikely. Kernel versions 4.18.x, 4.14.x and 3.10.x are believed to be vulnerable.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 18.04
- Debian Linux: 8.0, 9.0
- Linux kernel: from 3.1 before 3.16.59; from 3.17 before 3.18.124; from 3.19 before 4.4.159; from 4.5 before 4.9.130; from 4.10 before 4.14.73; from 4.15 before 4.18.11 — fixed in 3.16.59, 3.18.124, 4.14.73, 4.18.11, 4.4.159, 4.9.130
- RedHat Enterprise Linux Eus: 7.4, 7.6
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 7.4, 7.6
- RedHat Enterprise Linux Server Tus: 7.4, 7.6
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: Linux kernel 3.16.59, 3.18.124, 4.14.73, 4.18.11. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/105388
- https://access.redhat.com/errata/RHSA-2018:3651
- https://access.redhat.com/errata/RHSA-2018:3666
- https://access.redhat.com/errata/RHSA-2019:1946
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-14633
- https://git.kernel.org/pub/scm/linux/kernel/git/mkp/scsi.git/commit/?h=4.19/scsi-fixes&id=1816494330a83f2a064499d8ed2797045641f92c
- https://git.kernel.org/pub/scm/linux/kernel/git/mkp/scsi.git/commit/?h=4.19/scsi-fixes&id=8c39e2699f8acb2e29782a834e56306da24937fe
- https://lists.debian.org/debian-lts-announce/2018/10/msg00003.html
- https://seclists.org/oss-sec/2018/q3/270
- https://usn.ubuntu.com/3775-1/
- https://usn.ubuntu.com/3775-2/
- https://usn.ubuntu.com/3776-1/
Get alerted when CVE-2018-14633 or the next vulnerability affects your stack