What’s Vulnerable › Vulnerabilities
CVE-2018-14637
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-11-30 · updated 2026-06-17
- Weakness: CWE-285
Description
The SAML broker consumer endpoint in Keycloak before version 4.6.0.Final ignores expiration conditions on SAML assertions. An attacker can exploit this vulnerability to perform a replay attack.
Affected products
- Keycloak: before 4.6.0 — fixed in 4.6.0
How to fix
Upgrade to a fixed version: Keycloak 4.6.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-14637
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-14637
Get alerted when CVE-2018-14637 or the next vulnerability affects your stack