What’s Vulnerable › Vulnerabilities

CVE-2018-14719

Description

FasterXML jackson-databind 2.x before 2.9.7 might allow remote attackers to execute arbitrary code by leveraging failure to block the blaze-ds-opt and blaze-ds-core classes from polymorphic deserialization.

Affected products

How to fix

Upgrade to a fixed version: FasterXML jackson-databind 2.6.7.3, 2.7.9.5, 2.8.11.3, 2.9.7; Oracle Global Lifecycle Management Opatch 11.2.0.3.23, 12.2.0.1.19, 13.9.4.2.1; Red Hat OpenShift Container Platform 4.18 3.11.153, 4.1.18, 4.6.26. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2018-14719 or the next vulnerability affects your stack