What’s Vulnerable › Vulnerabilities

CVE-2018-14851

Description

exif_process_IFD_in_MAKERNOTE in ext/exif/exif.c in PHP before 5.6.37, 7.0.x before 7.0.31, 7.1.x before 7.1.20, and 7.2.x before 7.2.8 allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via a crafted JPEG file.

Affected products

How to fix

Upgrade to a fixed version: PHP 7.0.31, 7.1.20, 7.2.8. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2018-14851 or the next vulnerability affects your stack