What’s Vulnerable › Vulnerabilities
CVE-2018-15142
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 18.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-08-13 · updated 2026-06-17
- Weakness: CWE-22
Description
Directory traversal in portal/import_template.php in versions of OpenEMR before 5.0.1.4 allows a remote attacker authenticated in the patient portal to execute arbitrary PHP code by writing a file with a PHP extension via the "docid" and "content" parameters and accessing it in the traversed directory.
Affected products
- openemr: before 5.0.1.4 — fixed in 5.0.1.4
How to fix
Upgrade to a fixed version: openemr 5.0.1.4. Check the vendor advisory for mitigations.
References
- https://github.com/openemr/openemr/pull/1765/files
- https://www.databreaches.net/openemr-patches-serious-vulnerabilities-uncovered-by-project-insecurity/
- https://www.exploit-db.com/exploits/45202/
- https://github.com/openemr/openemr/pull/1765/files
- https://www.databreaches.net/openemr-patches-serious-vulnerabilities-uncovered-by-project-insecurity/
- https://www.exploit-db.com/exploits/45202/
Get alerted when CVE-2018-15142 or the next vulnerability affects your stack