What’s Vulnerable › Vulnerabilities
CVE-2018-15145
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-08-13 · updated 2026-06-17
- Weakness: CWE-89
Description
Multiple SQL injection vulnerabilities in portal/add_edit_event_user.php in versions of OpenEMR before 5.0.1.4 allow a remote attacker to execute arbitrary SQL commands via the (1) eid, (2) userid, or (3) pid parameter.
Affected products
- openemr: before 5.0.1.4 — fixed in 5.0.1.4
How to fix
Upgrade to a fixed version: openemr 5.0.1.4. Check the vendor advisory for mitigations.
References
- https://github.com/openemr/openemr/pull/1758/files
- https://www.databreaches.net/openemr-patches-serious-vulnerabilities-uncovered-by-project-insecurity/
- https://github.com/openemr/openemr/pull/1758/files
- https://www.databreaches.net/openemr-patches-serious-vulnerabilities-uncovered-by-project-insecurity/
Get alerted when CVE-2018-15145 or the next vulnerability affects your stack