What’s Vulnerable › Vulnerabilities
CVE-2018-15154
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 10.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-08-15 · updated 2026-06-17
- Weakness: CWE-78
Description
OS command injection occurring in versions of OpenEMR before 5.0.1.4 allows a remote authenticated attacker to execute arbitrary commands by making a crafted request to interface/billing/sl_eob_search.php after modifying the "print_command" global variable in interface/super/edit_globals.php.
Affected products
- openemr: before 5.0.1.4 — fixed in 5.0.1.4
How to fix
Upgrade to a fixed version: openemr 5.0.1.4. Check the vendor advisory for mitigations.
References
- https://github.com/openemr/openemr/pull/1757
- https://insecurity.sh/reports/openemr.pdf
- https://www.databreaches.net/openemr-patches-serious-vulnerabilities-uncovered-by-project-insecurity/
- https://www.open-emr.org/wiki/index.php/OpenEMR_Patches
- https://github.com/openemr/openemr/pull/1757
- https://insecurity.sh/reports/openemr.pdf
- https://www.databreaches.net/openemr-patches-serious-vulnerabilities-uncovered-by-project-insecurity/
- https://www.open-emr.org/wiki/index.php/OpenEMR_Patches
Get alerted when CVE-2018-15154 or the next vulnerability affects your stack