What’s Vulnerable › Vulnerabilities
CVE-2018-15361
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-05 · updated 2026-06-17
- Weakness: CWE-124
Description
UltraVNC revision 1198 has a buffer underflow vulnerability in VNC client code, which can potentially result in code execution. This attack appears to be exploitable via network connectivity. This vulnerability has been fixed in revision 1199.
Affected products
- Kaspersky Lab UltraVNC: before 1.2.2.3 — fixed in 1.2.2.3
How to fix
Upgrade to a fixed version: Kaspersky Lab UltraVNC 1.2.2.3. Check the vendor advisory for mitigations.
References
- https://cert-portal.siemens.com/productcert/pdf/ssa-927095.pdf
- https://ics-cert.kaspersky.com/advisories/klcert-advisories/2019/03/01/klcert-19-003-ultravnc-buffer-underwrite/
- https://www.us-cert.gov/ics/advisories/icsa-20-161-06
- https://cert-portal.siemens.com/productcert/pdf/ssa-927095.pdf
- https://ics-cert.kaspersky.com/advisories/klcert-advisories/2019/03/01/klcert-19-003-ultravnc-buffer-underwrite/
- https://www.us-cert.gov/ics/advisories/icsa-20-161-06
Get alerted when CVE-2018-15361 or the next vulnerability affects your stack