What’s Vulnerable › Vulnerabilities
CVE-2018-15420: Cisco Webex Network Recording Player and Cisco Webex Player Remote Code Execution Vulnerabilities
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-10-05 · updated 2026-06-17
- Weakness: CWE-20
Description
A vulnerability in the Cisco Webex Network Recording Player for Microsoft Windows and the Cisco Webex Player for Microsoft Windows could allow an attacker to execute arbitrary code on an affected system. The vulnerability exist because the affected software improperly validates Advanced Recording Format (ARF) and Webex Recording Format (WRF) files. An attacker could exploit this vulnerability by sending a user a malicious ARF or WRF file via a link or an email attachment and persuading the user to open the file by using the affected software. A successful exploit could allow the attacker to execute arbitrary code on the affected system.
Affected products
- Cisco Webex Business Suite 32: before 32.15.30 — fixed in 32.15.30
- Cisco Webex Business Suite 33: before 33.3 — fixed in 33.3
- Cisco WebEx WRF Player: before 1.3.37 — fixed in 1.3.37
- Cisco WebEx Meetings Server: 2.5-maintenance_release2_patch1, 2.5-maintenance_release5_patch1, 2.5-maintenance_release6_patch2, 2.5-maintenance_release6_patch3, 2.5-maintenance_release6_patch4, 2.5.1.29 (+12)
How to fix
Upgrade to a fixed version: Cisco Webex Business Suite 32 32.15.30; Cisco Webex Business Suite 33 33.3; Cisco WebEx WRF Player 1.3.37. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/105520
- http://www.securitytracker.com/id/1041795
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20181003-webex-rce
- http://www.securityfocus.com/bid/105520
- http://www.securitytracker.com/id/1041795
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20181003-webex-rce
Get alerted when CVE-2018-15420 or the next vulnerability affects your stack