What’s Vulnerable › Vulnerabilities
CVE-2018-15465: Cisco Adaptive Security Appliance Software Privilege Escalation Vulnerability
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-12-24 · updated 2026-06-17
- Weakness: CWE-285
Description
A vulnerability in the authorization subsystem of Cisco Adaptive Security Appliance (ASA) Software could allow an authenticated, but unprivileged (levels 0 and 1), remote attacker to perform privileged actions by using the web management interface. The vulnerability is due to improper validation of user privileges when using the web management interface. An attacker could exploit this vulnerability by sending specific HTTP requests via HTTPS to an affected device as an unprivileged user. An exploit could allow the attacker to retrieve files (including the running configuration) from the device or to upload and replace software images on the device.
Affected products
- Cisco ASA Software: before 9.4.4.29; from 9.5 before 9.6.4.20; from 9.7 before 9.8.3.18; from 9.9 before 9.9.2.36; from 9.10 before 9.10.1.7 — fixed in 9.10.1.7, 9.4.4.29, 9.6.4.20, 9.8.3.18, 9.9.2.36
How to fix
Upgrade to a fixed version: Cisco ASA Software 9.10.1.7, 9.4.4.29, 9.6.4.20, 9.8.3.18. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/106256
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20181219-asa-privesc
- https://www.tenable.com/security/research/tra-2018-46
- http://www.securityfocus.com/bid/106256
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20181219-asa-privesc
- https://www.tenable.com/security/research/tra-2018-46
Get alerted when CVE-2018-15465 or the next vulnerability affects your stack