What’s Vulnerable › Vulnerabilities
CVE-2018-15501
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-08-18 · updated 2026-06-17
- Weakness: CWE-125
Description
In ng_pkt in transports/smart_pkt.c in libgit2 before 0.26.6 and 0.27.x before 0.27.4, a remote attacker can send a crafted smart-protocol "ng" packet that lacks a '\0' byte to trigger an out-of-bounds read that leads to DoS.
Affected products
- Debian Linux: 8.0, 9.0
- libgit2: before 0.26.6; from 0.27.0 before 0.27.4 — fixed in 0.26.6, 0.27.4
How to fix
Upgrade to a fixed version: libgit2 0.26.6, 0.27.4. Check the vendor advisory for mitigations.
References
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=9406
- https://bugzilla.suse.com/show_bug.cgi?id=1104641
- https://github.com/libgit2/libgit2/commit/1f9a8510e1d2f20ed7334eeeddb92c4dd8e7c649
- https://github.com/libgit2/libgit2/releases/tag/v0.26.6
- https://github.com/libgit2/libgit2/releases/tag/v0.27.4
- https://lists.debian.org/debian-lts-announce/2018/08/msg00024.html
- https://lists.debian.org/debian-lts-announce/2022/03/msg00031.html
- https://www.pro-linux.de/sicherheit/2/44650/denial-of-service-in-libgit2.html
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=9406
- https://bugzilla.suse.com/show_bug.cgi?id=1104641
- https://github.com/libgit2/libgit2/commit/1f9a8510e1d2f20ed7334eeeddb92c4dd8e7c649
- https://github.com/libgit2/libgit2/releases/tag/v0.26.6
Get alerted when CVE-2018-15501 or the next vulnerability affects your stack