What’s Vulnerable › Vulnerabilities
CVE-2018-15518
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-12-26 · updated 2026-06-17
- Weakness: CWE-415
Description
QXmlStream in Qt 5.x before 5.11.3 has a double-free or corruption during parsing of a specially crafted illegal XML document.
Affected products
- Debian Linux: 8.0, 9.0
- openSUSE Leap: 42.3
- Qt: from 5.5.0 before 5.11.3 — fixed in 5.11.3
How to fix
Upgrade to a fixed version: Qt 5.11.3. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2018-12/msg00066.html
- http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00057.html
- http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00071.html
- http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00073.html
- http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00090.html
- https://access.redhat.com/errata/RHSA-2019:2135
- https://access.redhat.com/errata/RHSA-2019:3390
- https://blog.qt.io/blog/2018/12/04/qt-5-11-3-released-important-security-updates/
- https://blog.qt.io/blog/2018/12/04/qt-5-11-3-released-important-security-updates/
- https://blog.qt.io/blog/2018/12/04/qt-5-11-3-released-important-security-updates/
- https://blog.qt.io/blog/2018/12/04/qt-5-11-3-released-important-security-updates/
- https://codereview.qt-project.org/#/c/236691/
Get alerted when CVE-2018-15518 or the next vulnerability affects your stack