What’s Vulnerable › Vulnerabilities
CVE-2018-15560
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-08-20 · updated 2026-06-17
- Weakness: CWE-190
Description
PyCryptodome before 3.6.6 has an integer overflow in the data_len variable in AESNI.c, related to the AESNI_encrypt and AESNI_decrypt functions, leading to the mishandling of messages shorter than 16 bytes.
Affected products
- Pycryptodome: before 3.6.6 — fixed in 3.6.6
How to fix
Upgrade to a fixed version: Pycryptodome 3.6.6. Check the vendor advisory for mitigations.
References
- https://github.com/Legrandin/pycryptodome/issues/198
- https://whitehatck01.blogspot.com/2018/08/integer-overflow-vulnerability-in.html
- https://github.com/Legrandin/pycryptodome/issues/198
- https://whitehatck01.blogspot.com/2018/08/integer-overflow-vulnerability-in.html
Get alerted when CVE-2018-15560 or the next vulnerability affects your stack