What’s Vulnerable › Vulnerabilities
CVE-2018-15572
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-08-20 · updated 2026-06-17
Description
The spectre_v2_select_mitigation function in arch/x86/kernel/cpu/bugs.c in the Linux kernel before 4.18.1 does not always fill RSB upon a context switch, which makes it easier for attackers to conduct userspace-userspace spectreRSB attacks.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 18.04
- Debian Linux: 8.0, 9.0
- Linux kernel: before 4.18.1 — fixed in 4.18.1
How to fix
Upgrade to a fixed version: Linux kernel 4.18.1. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=fdf82a7856b32d905c39afc85e34364491e46346
- https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.18.1
- https://github.com/torvalds/linux/commit/fdf82a7856b32d905c39afc85e34364491e46346
- https://lists.debian.org/debian-lts-announce/2018/10/msg00003.html
- https://usn.ubuntu.com/3775-1/
- https://usn.ubuntu.com/3775-2/
- https://usn.ubuntu.com/3776-1/
- https://usn.ubuntu.com/3776-2/
- https://usn.ubuntu.com/3777-1/
- https://usn.ubuntu.com/3777-2/
- https://usn.ubuntu.com/3777-3/
- https://www.debian.org/security/2018/dsa-4308
Get alerted when CVE-2018-15572 or the next vulnerability affects your stack