What’s Vulnerable › Vulnerabilities
CVE-2018-15580
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-26 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-Site Scripting (XSS) vulnerability in adm/contentformupdate.php in gnuboard5 before 5.3.1.6 allows remote attackers to inject arbitrary web script or HTML.
Affected products
- gnuboard5: before 5.3.1.6 — fixed in 5.3.1.6
How to fix
Upgrade to a fixed version: gnuboard5 5.3.1.6. Check the vendor advisory for mitigations.
References
- https://github.com/gnuboard/gnuboard5/commit/b1fc952c7600b825c4b02e2789ddafdea18c8d13#diff-4182a3e8b74f6eb325c45862f8f26e76
- https://github.com/gnuboard/gnuboard5/commit/b1fc952c7600b825c4b02e2789ddafdea18c8d13#diff-4182a3e8b74f6eb325c45862f8f26e76
Get alerted when CVE-2018-15580 or the next vulnerability affects your stack