What’s Vulnerable › Vulnerabilities
CVE-2018-15594
- Severity: medium (CVSS 5.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-08-20 · updated 2026-06-17
- Weakness: CWE-200
Description
arch/x86/kernel/paravirt.c in the Linux kernel before 4.18.1 mishandles certain indirect calls, which makes it easier for attackers to conduct Spectre-v2 attacks against paravirtual guests.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 18.04
- Debian Linux: 8.0, 9.0
- Linux kernel: before 4.18.1 — fixed in 4.18.1
How to fix
Upgrade to a fixed version: Linux kernel 4.18.1. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=5800dc5c19f34e6e03b5adab1282535cb102fafd
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00043.html
- http://www.securityfocus.com/bid/105120
- http://www.securitytracker.com/id/1041601
- https://access.redhat.com/errata/RHSA-2019:2029
- https://access.redhat.com/errata/RHSA-2019:2043
- https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.18.1
- https://github.com/torvalds/linux/commit/5800dc5c19f34e6e03b5adab1282535cb102fafd
- https://lists.debian.org/debian-lts-announce/2018/10/msg00003.html
- https://twitter.com/grsecurity/status/1029324426142199808
- https://usn.ubuntu.com/3775-1/
- https://usn.ubuntu.com/3775-2/
Get alerted when CVE-2018-15594 or the next vulnerability affects your stack