What’s Vulnerable › Vulnerabilities
CVE-2018-15727
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 64.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-08-29 · updated 2026-06-17
- Weakness: CWE-287
Description
Grafana 2.x, 3.x, and 4.x before 4.6.4 and 5.x before 5.2.3 allows authentication bypass because an attacker can generate a valid "remember me" cookie knowing only a username of an LDAP or OAuth user.
Affected products
- Grafana: from 2.0.0 through 2.1.2; from 3.0.0 through 3.1.1; from 4.0.0 before 4.6.4; from 5.0.0 before 5.2.3 — fixed in 4.6.4, 5.2.3
- Red Hat Ceph Storage: 3.0
How to fix
Upgrade to a fixed version: Grafana 4.6.4, 5.2.3. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/105184
- https://access.redhat.com/errata/RHSA-2018:3829
- https://access.redhat.com/errata/RHSA-2019:0019
- https://grafana.com/blog/2018/08/29/grafana-5.2.3-and-4.6.4-released-with-important-security-fix/
- http://www.securityfocus.com/bid/105184
- https://access.redhat.com/errata/RHSA-2018:3829
- https://access.redhat.com/errata/RHSA-2019:0019
- https://grafana.com/blog/2018/08/29/grafana-5.2.3-and-4.6.4-released-with-important-security-fix/
Get alerted when CVE-2018-15727 or the next vulnerability affects your stack