What’s Vulnerable › Vulnerabilities
CVE-2018-15758: Privilege Escalation in spring-security-oauth2
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-10-18 · updated 2026-06-17
Description
Spring Security OAuth, versions 2.3 prior to 2.3.4, and 2.2 prior to 2.2.3, and 2.1 prior to 2.1.3, and 2.0 prior to 2.0.16, and older unsupported versions could be susceptible to a privilege escalation under certain conditions. A malicious user or attacker can craft a request to the approval endpoint that can modify the previously saved authorization request and lead to a privilege escalation on the subsequent approval. This scenario can happen if the application is configured to use a custom approval endpoint that declares AuthorizationRequest as a controller method argument. This vulnerability exposes applications that meet all of the following requirements: Act in the role of an Authorization Server (e.g. @EnableAuthorizationServer) and use a custom Approval Endpoint that declares AuthorizationRequest as a controller method argument. This vulnerability does not expose applications that: Act in the role of an Authorization Server and use the default Approval Endpoint, act in the role of a Resource Server only (e.g. @EnableResourceServer), act in the role of a Client only (e.g. @EnableOAuthClient).
Affected products
- Pivotal Spring Security OAuth: through 1.0.5; from 2.0.0 before 2.0.16; from 2.1.0 before 2.1.3; from 2.2.0 before 2.2.3; from 2.3.0 before 2.3.4 — fixed in 2.0.16, 2.1.3, 2.2.3, 2.3.4
How to fix
Upgrade to a fixed version: Pivotal Spring Security OAuth 2.0.16, 2.1.3, 2.2.3, 2.3.4. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/105687
- https://access.redhat.com/errata/RHSA-2019:2413
- https://pivotal.io/security/cve-2018-15758
- http://www.securityfocus.com/bid/105687
- https://access.redhat.com/errata/RHSA-2019:2413
- https://pivotal.io/security/cve-2018-15758
Get alerted when CVE-2018-15758 or the next vulnerability affects your stack