What’s Vulnerable › Vulnerabilities
CVE-2018-15761: UAA Privilege Escalation
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-11-19 · updated 2026-06-17
Description
Cloud Foundry UAA release, versions prior to v64.0, and UAA, versions prior to 4.23.0, contains a validation error which allows for privilege escalation. A remote authenticated user may modify the url and content of a consent page to gain a token with arbitrary scopes that escalates their privileges.
Affected products
- Cloud Foundry UAA: before 4.23.0 — fixed in 4.23.0
- Pivotal Software Cloudfoundry Uaa Release: before 64.0 — fixed in 64.0
How to fix
Upgrade to a fixed version: Cloud Foundry UAA 4.23.0; Pivotal Software Cloudfoundry Uaa Release 64.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2018-15761 or the next vulnerability affects your stack