What’s Vulnerable › Vulnerabilities
CVE-2018-15781: DSA-2019-022: Dell Wyse Password Encoder Hard-coded Cryptographic Key Vulnerability
- Severity: high (CVSS 8.0 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-02-13 · updated 2026-06-17
- Weakness: CWE-798
Description
The Dell Wyse Password Encoder in ThinLinux2 versions prior to 2.1.0.01 contain a Hard-coded Cryptographic Key vulnerability. An unauthenticated remote attacker could reverse engineer the cryptographic system used in the Dell Wyse Password Encoder to discover the hard coded private key and decrypt locally stored cipher text.
Affected products
- Dell Wyse Password Encoder: from 2.0 before 2.1.0.01 — fixed in 2.1.0.01
How to fix
Upgrade to a fixed version: Dell Wyse Password Encoder 2.1.0.01. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2018-15781 or the next vulnerability affects your stack