What’s Vulnerable › Vulnerabilities
CVE-2018-15784: DSA-2019-001: Dell Networking OS10 Improper Certificate Validation Vulnerability
- Severity: high (CVSS 7.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-01-18 · updated 2026-06-17
- Weakness: CWE-295
Description
Dell Networking OS10 versions prior to 10.4.3.0 contain a vulnerability in the Phone Home feature which does not properly validate the server's certificate authority during TLS handshake. Use of an invalid or malicious certificate could potentially allow an attacker to spoof a trusted entity by using a man-in-the-middle (MITM) attack.
Affected products
- Dell Networking OS10: before 10.4.3.0 — fixed in 10.4.3.0
How to fix
Upgrade to a fixed version: Dell Networking OS10 10.4.3.0. Check the vendor advisory for mitigations.
References
- https://www.dell.com/support/article/us/en/04/sln315899/dsa-2019-001-dell-networking-os10-improper-certificate-validation-vulnerability?lang=en
- https://www.dell.com/support/article/us/en/04/sln315899/dsa-2019-001-dell-networking-os10-improper-certificate-validation-vulnerability?lang=en
Get alerted when CVE-2018-15784 or the next vulnerability affects your stack