What’s Vulnerable › Vulnerabilities
CVE-2018-15804
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-08-23 · updated 2026-06-17
Description
An issue was discovered in the MapR File System in MapR Converged Data Platform and MapR-XD 6.x and earlier. Under certain conditions, it is possible for MapR ticket credentials to become compromised, allowing a user to escalate their privileges to act as (aka impersonate) any other user, including cluster administrators, aka bug# 31935. This affects all users who have enabled security on the MapR platform and is fixed in mapr-patch-5.2.1.42646.GA-20180731093831, mapr-patch-5.2.2.44680.GA-20180802011430, mapr-patch-6.0.0.20171109191718.GA-20180802011420, and mapr-patch-6.0.1.20180404222005.GA-20180806214919.
Affected products
- MapR-MFS/CLDB: before 6.0.1 — fixed in 6.0.1
How to fix
Upgrade to a fixed version: MapR-MFS/CLDB 6.0.1. Check the vendor advisory for mitigations.
References
- https://mapr.com/support/s/article/MapR-Ticket-Credentials-can-become-compromised
- https://mapr.com/support/s/article/MapR-Ticket-Credentials-can-become-compromised
Get alerted when CVE-2018-15804 or the next vulnerability affects your stack