What’s Vulnerable › Vulnerabilities
CVE-2018-15909
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-08-27 · updated 2026-06-17
- Weakness: CWE-704
Description
In Artifex Ghostscript 9.23 before 2018-08-24, a type confusion using the .shfill operator could be used by attackers able to supply crafted PostScript files to crash the interpreter or potentially execute code.
Affected products
- Artifex Ghostscript: through 9.23
- Artifex Gpl Ghostscript: before 9.26 — fixed in 9.26
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04
- Debian Linux: 8.0
- Ivanti Connect Secure (Pulse Secure): from 8.2r1.0 before 8.2r12.1; from 8.3r1 before 8.3r7.1; from 9.0r1 before 9.0r3.4 — fixed in 8.2r12.1, 8.3r7.1, 9.0r3.4
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 7.6
- RedHat Enterprise Linux Server Eus: 7.6
- RedHat Enterprise Linux Server Tus: 7.6
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: Artifex Gpl Ghostscript 9.26; Ivanti Connect Secure (Pulse Secure) 8.2r12.1, 8.3r7.1, 9.0r3.4. Check the vendor advisory for mitigations.
References
- http://git.ghostscript.com/?p=ghostpdl.git%3Ba=commit%3Bh=0b6cd1918e1ec4ffd087400a754a845180a4522b
- http://git.ghostscript.com/?p=ghostpdl.git%3Ba=commit%3Bh=e01e77a36cbb2e0277bc3a63852244bec41be0f6
- http://www.securityfocus.com/bid/105178
- https://access.redhat.com/errata/RHSA-2018:3650
- https://kb.pulsesecure.net/articles/Pulse_Security_Advisories/SA44101
- https://lists.debian.org/debian-lts-announce/2018/09/msg00015.html
- https://security.gentoo.org/glsa/201811-12
- https://support.f5.com/csp/article/K24803507?utm_source=f5support&%3Butm_medium=RSS
- https://usn.ubuntu.com/3768-1/
- https://www.kb.cert.org/vuls/id/332928
- http://git.ghostscript.com/?p=ghostpdl.git%3Ba=commit%3Bh=0b6cd1918e1ec4ffd087400a754a845180a4522b
- http://git.ghostscript.com/?p=ghostpdl.git%3Ba=commit%3Bh=e01e77a36cbb2e0277bc3a63852244bec41be0f6
Get alerted when CVE-2018-15909 or the next vulnerability affects your stack