What’s Vulnerable › Vulnerabilities
CVE-2018-16050
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-10-03 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue was discovered in GitLab Community and Enterprise Edition 11.1.x before 11.1.5 and 11.2.x before 11.2.2. There is Persistent XSS in the Merge Request Changes View.
Affected products
- GitLab: from 10.7.0 through 10.7.7; from 10.8.0 through 10.8.6; from 11.1.0 before 11.1.5; from 11.2.0 before 11.2.2 — fixed in 11.1.5, 11.2.2
How to fix
Upgrade to a fixed version: GitLab 11.1.5, 11.2.2. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/2018/08/28/security-release-gitlab-11-dot-2-dot-2-released/
- https://gitlab.com/gitlab-org/gitlab-ce/issues/49085
- https://about.gitlab.com/2018/08/28/security-release-gitlab-11-dot-2-dot-2-released/
- https://gitlab.com/gitlab-org/gitlab-ce/issues/49085
Get alerted when CVE-2018-16050 or the next vulnerability affects your stack