What’s Vulnerable › Vulnerabilities
CVE-2018-16055
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 11.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-09-26 · updated 2026-06-17
- Weakness: CWE-78
Description
An authenticated command injection vulnerability exists in status_interfaces.php via dhcp_relinquish_lease() in pfSense before 2.4.4 due to its passing user input from the $_POST parameters "ifdescr" and "ipv" to a shell without escaping the contents of the variables. This allows an authenticated WebGUI user with privileges for the affected page to execute commands in the context of the root user when submitting a request to relinquish a DHCP lease for an interface which is configured to obtain its address via DHCP.
Affected products
- Netgate pfSense: before 2.4.4 — fixed in 2.4.4
How to fix
Upgrade to a fixed version: Netgate pfSense 2.4.4. Check the vendor advisory for mitigations.
References
- https://doddsecurity.com/190/command-injection-on-pfsense-firewalls/
- https://www.pfsense.org/security/advisories/pfSense-SA-18_08.webgui.asc
- https://doddsecurity.com/190/command-injection-on-pfsense-firewalls/
- https://www.pfsense.org/security/advisories/pfSense-SA-18_08.webgui.asc
Get alerted when CVE-2018-16055 or the next vulnerability affects your stack