What’s Vulnerable › Vulnerabilities
CVE-2018-16146
- Severity: high (CVSS 7.2 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-09-05 · updated 2026-06-17
- Weakness: CWE-78
Description
The web management console of Opsview Monitor 5.4.x before 5.4.2 provides functionality accessible by an authenticated administrator to test notifications that are triggered under certain configurable events. The value parameter is not properly sanitized, leading to arbitrary command injection with the privileges of the nagios user account.
Affected products
- Opsview: from 5.4.0 before 5.4.2 — fixed in 5.4.2
How to fix
Upgrade to a fixed version: Opsview 5.4.2. Check the vendor advisory for mitigations.
References
- https://knowledge.opsview.com/v5.4/docs/whats-new
- https://seclists.org/fulldisclosure/2018/Sep/3
- https://www.coresecurity.com/advisories/opsview-monitor-multiple-vulnerabilities
- https://knowledge.opsview.com/v5.4/docs/whats-new
- https://seclists.org/fulldisclosure/2018/Sep/3
- https://www.coresecurity.com/advisories/opsview-monitor-multiple-vulnerabilities
Get alerted when CVE-2018-16146 or the next vulnerability affects your stack