What’s Vulnerable › Vulnerabilities
CVE-2018-16153
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-12 · updated 2026-06-17
- Weakness: CWE-522
Description
An issue was discovered in Apereo Opencast 4.x through 10.x before 10.6. It sends system digest credentials during authentication attempts to arbitrary external services in some situations.
Affected products
- opencast: from 4.0 before 10.6 — fixed in 10.6
How to fix
Upgrade to a fixed version: opencast 10.6. Check the vendor advisory for mitigations.
References
- https://docs.opencast.org/r/10.x/admin/#changelog
- https://github.com/advisories/GHSA-hcxx-mp6g-6gr9
- https://github.com/opencast/opencast/commit/776d5588f39c61eb04c03bb955416c4f77629d51
- https://www.apereo.org/projects/opencast/news
- https://docs.opencast.org/r/10.x/admin/#changelog
- https://github.com/advisories/GHSA-hcxx-mp6g-6gr9
- https://github.com/opencast/opencast/commit/776d5588f39c61eb04c03bb955416c4f77629d51
- https://www.apereo.org/projects/opencast/news
Get alerted when CVE-2018-16153 or the next vulnerability affects your stack