What’s Vulnerable › Vulnerabilities
CVE-2018-16276
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-08-31 · updated 2026-06-17
- Weakness: CWE-787
Description
An issue was discovered in yurex_read in drivers/usb/misc/yurex.c in the Linux kernel before 4.17.7. Local attackers could use user access read/writes with incorrect bounds checking in the yurex USB driver to crash the kernel or potentially escalate privileges.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 18.04
- Debian Linux: 8.0, 9.0
- Linux kernel: from 2.6.37 before 3.16.58; from 3.17 before 3.18.116; from 3.19 before 4.4.141; from 4.5 before 4.9.113; from 4.10 before 4.14.56; from 4.15 before 4.17.7 — fixed in 3.16.58, 3.18.116, 4.14.56, 4.17.7, 4.4.141, 4.9.113
How to fix
Upgrade to a fixed version: Linux kernel 3.16.58, 3.18.116, 4.14.56, 4.17.7. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=f1e255d60ae66a9f672ff9a207ee6cd8e33d2679
- https://bugzilla.suse.com/show_bug.cgi?id=1106095
- https://bugzilla.suse.com/show_bug.cgi?id=1115593
- https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.17.7
- https://github.com/torvalds/linux/commit/f1e255d60ae66a9f672ff9a207ee6cd8e33d2679
- https://lists.debian.org/debian-lts-announce/2018/10/msg00003.html
- https://usn.ubuntu.com/3776-1/
- https://usn.ubuntu.com/3776-2/
- https://usn.ubuntu.com/3847-1/
- https://usn.ubuntu.com/3847-2/
- https://usn.ubuntu.com/3847-3/
- https://usn.ubuntu.com/3849-1/
Get alerted when CVE-2018-16276 or the next vulnerability affects your stack