What’s Vulnerable › Vulnerabilities
CVE-2018-16362
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-09-02 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue was discovered in the Source Integration plugin before 1.5.9 and 2.x before 2.1.5 for MantisBT. A cross-site scripting (XSS) vulnerability in the Manage Repository and Changesets List pages allows execution of arbitrary code (if CSP settings permit it) via repo_manage_page.php or list.php.
Affected products
- mantisbt Source Integration: before 1.5.9; from 2.0.0 before 2.1.5 — fixed in 1.5.9, 2.1.5
How to fix
Upgrade to a fixed version: mantisbt Source Integration 1.5.9, 2.1.5. Check the vendor advisory for mitigations.
References
- https://github.com/mantisbt-plugins/source-integration/issues/286
- https://github.com/mantisbt-plugins/source-integration/releases/tag/v1.5.9
- https://github.com/mantisbt-plugins/source-integration/releases/tag/v2.1.5
- https://github.com/mantisbt-plugins/source-integration/issues/286
- https://github.com/mantisbt-plugins/source-integration/releases/tag/v1.5.9
- https://github.com/mantisbt-plugins/source-integration/releases/tag/v2.1.5
Get alerted when CVE-2018-16362 or the next vulnerability affects your stack