What’s Vulnerable › Vulnerabilities
CVE-2018-16395
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 10.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-11-16 · updated 2026-06-17
Description
An issue was discovered in the OpenSSL library in Ruby before 2.3.8, 2.4.x before 2.4.5, 2.5.x before 2.5.2, and 2.6.x before 2.6.0-preview3. When two OpenSSL::X509::Name objects are compared using ==, depending on the ordering, non-equal objects may return true. When the first argument is one character longer than the second, or the second argument contains a character that is one less than a character in the same position of the first argument, the result of == will be true. This could be leveraged to create an illegitimate certificate that may be accepted as legitimate and then used in signing or encryption operations.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 18.10
- Debian Linux: 8.0, 9.0
- Red Hat Enterprise Linux: 7.4
- ruby-lang Openssl: before 2.1.2 — fixed in 2.1.2
- Ruby: from 2.3.0 through 2.3.7; from 2.4.0 through 2.4.4; from 2.5.0 through 2.5.1; 2.6.0-preview1, 2.6.0-preview2
How to fix
Upgrade to a fixed version: ruby-lang Openssl 2.1.2. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00036.html
- http://www.securitytracker.com/id/1042105
- https://access.redhat.com/errata/RHSA-2018:3729
- https://access.redhat.com/errata/RHSA-2018:3730
- https://access.redhat.com/errata/RHSA-2018:3731
- https://access.redhat.com/errata/RHSA-2018:3738
- https://access.redhat.com/errata/RHSA-2019:1948
- https://access.redhat.com/errata/RHSA-2019:2565
- https://hackerone.com/reports/387250
- https://lists.debian.org/debian-lts-announce/2018/10/msg00020.html
- https://security.netapp.com/advisory/ntap-20190221-0002/
- https://usn.ubuntu.com/3808-1/
Get alerted when CVE-2018-16395 or the next vulnerability affects your stack