What’s Vulnerable › Vulnerabilities
CVE-2018-16460
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-09-07 · updated 2026-06-17
- Weakness: CWE-77
Description
A command Injection in ps package versions <1.0.0 for Node.js allowed arbitrary commands to be executed when attacker controls the PID.
Affected products
- https://github.com/UmbraEngineering ps: before 1.0.0 — fixed in 1.0.0
How to fix
Upgrade to a fixed version: https://github.com/UmbraEngineering ps 1.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2018-16460 or the next vulnerability affects your stack