What’s Vulnerable › Vulnerabilities
CVE-2018-16466
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-10-30 · updated 2026-06-17
- Weakness: CWE-284
Description
Improper revalidation of permissions in Nextcloud Server prior to 14.0.0, 13.0.6 and 12.0.11 lead to not accepting access restrictions by acess tokens.
Affected products
- Nextcloud Server: before 12.0.11; from 13.0.0 before 13.0.6; 14.0.0-beta1, 14.0.0-beta2, 14.0.0-beta3, 14.0.0-beta4, 14.0.0-rc1, 14.0.0-rc2 — fixed in 12.0.11, 13.0.6
How to fix
Upgrade to a fixed version: Nextcloud Server 12.0.11, 13.0.6. Check the vendor advisory for mitigations.
References
- https://hackerone.com/reports/388515
- https://nextcloud.com/security/advisory/?id=NC-SA-2018-010
- https://hackerone.com/reports/388515
- https://nextcloud.com/security/advisory/?id=NC-SA-2018-010
Get alerted when CVE-2018-16466 or the next vulnerability affects your stack