What’s Vulnerable › Vulnerabilities
CVE-2018-16469
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-10-30 · updated 2026-06-17
- Weakness: CWE-400
Description
The merge.recursive function in the merge package <1.2.1 can be tricked into adding or modifying properties of the Object prototype. These properties will be present on all objects allowing for a denial of service attack.
Affected products
- @ianwalter/merge: before 1.2.1 — fixed in 1.2.1
How to fix
Upgrade to a fixed version: @ianwalter/merge 1.2.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2018-16469 or the next vulnerability affects your stack