What’s Vulnerable › Vulnerabilities
CVE-2018-16471
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-11-13 · updated 2026-06-17
- Weakness: CWE-79
Description
There is a possible XSS vulnerability in Rack before 2.0.6 and 1.6.11. Carefully crafted requests can impact the data returned by the `scheme` method on `Rack::Request`. Applications that expect the scheme to be limited to 'http' or 'https' and do not escape the return value could be vulnerable to an XSS attack. Note that applications using the normal escaping mechanisms provided by Rails may not impacted, but applications that bypass the escaping mechanisms, or do not use them may be vulnerable.
Affected products
- Debian Linux: 8.0
- Rack Project Rack: from 1.6.0 before 1.6.11; from 2.0.0 before 2.0.6 — fixed in 1.6.11, 2.0.6
How to fix
Upgrade to a fixed version: Rack Project Rack 1.6.11, 2.0.6. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00032.html
- http://lists.opensuse.org/opensuse-security-announce/2020-02/msg00016.html
- https://groups.google.com/forum/#%21topic/rubyonrails-security/GKsAFT924Ag
- https://lists.debian.org/debian-lts-announce/2018/11/msg00022.html
- https://usn.ubuntu.com/4089-1/
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00032.html
- http://lists.opensuse.org/opensuse-security-announce/2020-02/msg00016.html
- https://groups.google.com/forum/#%21topic/rubyonrails-security/GKsAFT924Ag
- https://lists.debian.org/debian-lts-announce/2018/11/msg00022.html
- https://usn.ubuntu.com/4089-1/
Get alerted when CVE-2018-16471 or the next vulnerability affects your stack