What’s Vulnerable › Vulnerabilities
CVE-2018-16476
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-11-30 · updated 2026-06-17
- Weakness: CWE-284
Description
A Broken Access Control vulnerability in Active Job versions >= 4.2.0 allows an attacker to craft user input which can cause Active Job to deserialize it using GlobalId and give them access to information that they should not have. This vulnerability has been fixed in versions 4.2.11, 5.0.7.1, 5.1.6.1, and 5.2.1.1.
Affected products
- CloudForms: 4.6
- Ruby on Rails: from 4.2.0 before 4.2.11; from 5.0.0 before 5.0.7.1; from 5.1.0 before 5.1.6.1; from 5.2.0 before 5.2.1.1 — fixed in 4.2.11, 5.0.7.1, 5.1.6.1, 5.2.1.1
How to fix
Upgrade to a fixed version: Ruby on Rails 4.2.11, 5.0.7.1, 5.1.6.1, 5.2.1.1. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2019:0600
- https://groups.google.com/d/msg/rubyonrails-security/FL4dSdzr2zw/zjKVhF4qBAAJ
- https://weblog.rubyonrails.org/2018/11/27/Rails-4-2-5-0-5-1-5-2-have-been-released/
- https://access.redhat.com/errata/RHSA-2019:0600
- https://groups.google.com/d/msg/rubyonrails-security/FL4dSdzr2zw/zjKVhF4qBAAJ
- https://weblog.rubyonrails.org/2018/11/27/Rails-4-2-5-0-5-1-5-2-have-been-released/
Get alerted when CVE-2018-16476 or the next vulnerability affects your stack