What’s Vulnerable › Vulnerabilities
CVE-2018-16480
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-02-01 · updated 2026-06-17
- Weakness: CWE-79
Description
A XSS vulnerability was found in module public <0.1.4 that allows malicious Javascript code to run in the browser, due to the absence of sanitization of the file/folder names before rendering.
Affected products
- HackerOne public: before 0.1.4 — fixed in 0.1.4
How to fix
Upgrade to a fixed version: HackerOne public 0.1.4. Check the vendor advisory for mitigations.
References
- https://hackerone.com/reports/329950
- https://www.npmjs.com/package/public
- https://hackerone.com/reports/329950
- https://www.npmjs.com/package/public
Get alerted when CVE-2018-16480 or the next vulnerability affects your stack