What’s Vulnerable › Vulnerabilities
CVE-2018-16509
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 92.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-09-05 · updated 2026-06-17
Description
An issue was discovered in Artifex Ghostscript before 9.24. Incorrect "restoration of privilege" checking during handling of /invalidaccess exceptions could be used by attackers able to supply crafted PostScript to execute code using the "pipe" instruction.
Affected products
- Artifex Ghostscript: before 9.24 — fixed in 9.24
- Artifex Gpl Ghostscript: before 9.26 — fixed in 9.26
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04
- Debian Linux: 8.0, 9.0
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Server Eus: 7.5
- RedHat Enterprise Linux Workstation: 6.0, 7.0
How to fix
Upgrade to a fixed version: Artifex Ghostscript 9.24; Artifex Gpl Ghostscript 9.26. Check the vendor advisory for mitigations.
References
- http://git.ghostscript.com/?p=ghostpdl.git%3Ba=commit%3Bh=5516c614dc33662a2afdc377159f70218e67bde5
- http://git.ghostscript.com/?p=ghostpdl.git%3Ba=commit%3Bh=78911a01b67d590b4a91afac2e8417360b934156
- http://git.ghostscript.com/?p=ghostpdl.git%3Ba=commit%3Bh=79cccf641486a6595c43f1de1cd7ade696020a31
- http://git.ghostscript.com/?p=ghostpdl.git%3Ba=commitdiff%3Bh=520bb0ea7519aa3e79db78aaf0589dae02103764
- http://seclists.org/oss-sec/2018/q3/142
- http://www.securityfocus.com/bid/105122
- https://access.redhat.com/errata/RHSA-2018:2918
- https://access.redhat.com/errata/RHSA-2018:3760
- https://bugs.ghostscript.com/show_bug.cgi?id=699654
- https://lists.debian.org/debian-lts-announce/2018/09/msg00015.html
- https://security.gentoo.org/glsa/201811-12
- https://usn.ubuntu.com/3768-1/
Get alerted when CVE-2018-16509 or the next vulnerability affects your stack