What’s Vulnerable › Vulnerabilities
CVE-2018-16513
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-09-05 · updated 2026-06-17
- Weakness: CWE-704
Description
In Artifex Ghostscript before 9.24, attackers able to supply crafted PostScript files could use a type confusion in the setcolor function to crash the interpreter or possibly have unspecified other impact.
Affected products
- Artifex Ghostscript: before 9.24 — fixed in 9.24
- Artifex Gpl Ghostscript: before 9.26 — fixed in 9.26
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04
- Debian Linux: 8.0, 9.0
- Ivanti Connect Secure (Pulse Secure): from 8.2r1.0 before 8.2r12.1; from 8.3r1 before 8.3r7.1; from 9.0r1 before 9.0r3.4 — fixed in 8.2r12.1, 8.3r7.1, 9.0r3.4
How to fix
Upgrade to a fixed version: Artifex Ghostscript 9.24; Artifex Gpl Ghostscript 9.26; Ivanti Connect Secure (Pulse Secure) 8.2r12.1, 8.3r7.1, 9.0r3.4. Check the vendor advisory for mitigations.
References
- http://git.ghostscript.com/?p=ghostpdl.git%3Ba=commit%3Bh=b326a71659b7837d3acde954b18bda1a6f5e9498
- https://bugs.ghostscript.com/show_bug.cgi?id=699655
- https://kb.pulsesecure.net/articles/Pulse_Security_Advisories/SA44101
- https://lists.debian.org/debian-lts-announce/2018/09/msg00015.html
- https://security.gentoo.org/glsa/201811-12
- https://support.f5.com/csp/article/K22141757?utm_source=f5support&%3Butm_medium=RSS
- https://usn.ubuntu.com/3768-1/
- https://www.artifex.com/news/ghostscript-security-resolved/
- https://www.debian.org/security/2018/dsa-4288
- http://git.ghostscript.com/?p=ghostpdl.git%3Ba=commit%3Bh=b326a71659b7837d3acde954b18bda1a6f5e9498
- https://bugs.ghostscript.com/show_bug.cgi?id=699655
- https://kb.pulsesecure.net/articles/Pulse_Security_Advisories/SA44101
Get alerted when CVE-2018-16513 or the next vulnerability affects your stack